UBUNTU LINUX FOR
NON-GEeks

A Pain-Free, Project-
Based, Get-Things-Done
Guidebook

by Rickford Grant

NO STARCH
PRESS
San Francisco
Before entering the world of Linux, I had used just about every desktop operating system around. Despite the differences among them all, however, one thing that I eventually suffered from in each case was a kind of visual boredom. I suppose you might call it GUI fatigue.

It wasn’t that I was tired of using a graphical interface; it was just that I couldn’t help but get sick of looking at the same old icons, window borders, and color schemes. Of course, there were some changes that could be made, but it just wasn’t possible to get around the basic look and feel without add-ons that demanded a price in terms of performance.

One of the features of Linux that pleased me to no end, and continues to do so, is that users can drastically change the look of things. I don’t mean just the icons and backgrounds, but everything, including the actual window borders and controls. Add to that the variety of graphical desktop environments and window managers available for Linux, and you have a totally customizable system. Is it any wonder that there are so many more Linux
desktop screenshots out there on the Web than for any other system? If you
don’t believe me, just have a look at a site dedicated to Linux screenshots,
www.lynucs.org, and click the Screenshots link.

You may not be as fickle as I am in terms of the look and feel of your
system, but you can learn to use and enjoy all the graphical customization
power that Linux offers you as you work through this chapter.

**Project 7A: Creating a New User Account**

If you are reluctant to alter the look of your present setup, you can create a
new user account and experiment with making the changes in this chapter
when logged in to the new account. If you opt to go this route, your regular
home environment will remain untouched because look-and-feel customi-
zations that are performed in one user account do not affect other user
accounts. When you are all done with the project, you can then simply
delete the new user account. Either way, it’s up to you.

To set up a new user account, follow these steps:

1. Go to the **System** menu, and select **Administration ▶ Users and Groups**.
2. When prompted for your password, type it, and then click **Continue**.
The Users and Groups window will open.
3. In the Users and Groups window, click the **Add User** button, which will
   bring up a User Account Editor window.
4. Type a new username: **graphika**. In the Real Name field, you can type
   whatever you like; I used **Graphics Lover** in the example. Then move on
down to the Password section of the window, skipping over Contact
   Information, and type an easy-to-remember user password in the two
   password boxes; in this case, the one you’re using for your present account
   will do just fine. Once you’ve done all this, your window should look more
   or less like that in Figure 7-1.
5. If everything looks fine and dandy, click **OK** to close the window and get
   back to the Users and Groups window, which will now list your new user
   account right below your current one (see Figure 7-2).

Before using the graphika account, you need to give yourself user
privileges to install software while logged in with it. Normally, this privilege
is disabled by default on new user accounts, as you probably don’t want
your kids, workmates, or anyone else with their own user account on your
computer installing all sorts of weird stuff and screwing up your system
settings.
To change the privileges for the graphika account, click the **graphika** entry within the User list to highlight it. Once you’ve done that, click the **Properties** button. A new window, Settings for User graphika, will then appear. In that window, click the **User privileges** tab, and then check the box next to the words *Executing system administration tasks* (as shown in Figure 7-3). Once you’re done, click **OK**, and then exit the Users and Groups window by clicking **OK** again.
Chapter 7

Figure 7-3: Changing user account privileges

Logging In to Your New Account

To use this new account, go to the System menu and select Log Out (or just click the Logout button at the far-right corner of the top panel). When the logout window appears, click Log Out. After a few seconds, you will be back at the login screen. Type your new username in that window, and then press ENTER. After that type the new password for the account, and press ENTER again. You will soon be at the desktop for your new user account.

Switching Users

It’s worth knowing that there is another way to switch users other than simply logging out of one account and into another. This alternative approach is logically referred to as switching users. Switching users differs from the logout/login approach, in that you remain logged in to your original account while you log in to your other account (or while someone else with an account on your computer logs in to theirs). Going this route keeps all of the windows or applications you have open. These windows will not appear in the account you are switching to, but they will be there, conveniently waiting for you, when you switch back to the account from whence you came.

This is a good way to proceed if you plan to be switching back and forth between your two accounts. It is also a good approach when, say, your child needs to log in to his or her account for a moment to do a quick email check, burn a CD to play on the way to the beach, or print a file for school. When your child is done, you can quickly get back to what you were doing before without having to reopen files, web pages, or whatever else you happened to be dealing with at the time of the switch.
You can switch users in much the same way you would using the logout/login approach. After clicking the Quit button in the top panel, you can click Switch User instead of Log Out. You are then delivered to the login screen where you type the username and user password for the other account (each step followed by a press of the ENTER key), just as you would normally log in.

To get back to your original user account after going the switch-user route, just click the Quit button at the right corner of the top panel, click Switch User (if you plan to return shortly to the new account) or Log Out (if you don’t plan to return soon), and then once back at the login screen, type your original username, press ENTER, type your password, and press ENTER again. In the small window that then appears, click the Return to previous login button.

Another window will appear, in which you must type the user password of the account you are returning to. Type your password, click Unlock, and you will be back at your original desktop, with everything as it was when you last saw it, open windows and all. Pretty cool.

Logging In to Another Account in a Separate Window

If switching back and forth between accounts seems like too much of a hassle to you, there is yet another, almost surreal, alternative—logging in to another account in a separate window while still in your regular user account.

This being-two-places-at-the-same-time approach requires a little bit of work up front, but it provides a lot of convenience in the long run, not only when going through Project 7B on page 102, but also whenever one of those “Hey ‘rents, can I check my email for a second?” moments arises. To set things up so that you can do this, you need to install, set up, and use an application called Xnest. Here are the steps:

1. Run Synaptic, do a search for xnest, and install it.
2. Once Xnest is installed, close Synaptic, go to the Applications menu, and select Accessories ➤ Alacarte Menu Editor.
3. When the Alacarte Menu Editor window appears, click System Tools in the left pane, and then check the box next to New Login in Nested Window in the right pane. Click Close to finish.

After performing these steps, you can log in to your new account by going to the Applications menu and selecting System Tools ➤ New Login in Nested Window. An Xnest window will appear, and after a few seconds, the Ubuntu login screen will appear within that window. In that screen, type your new username (graphika, or whatever name you chose) and password as you would during any other login. Your new desktop will soon appear in the Xnest window (Figure 7-4).

When you are done with your Xnest session, click the logout button at the far right of the top panel, and then click Logout in the set of choices that appears. The Xnest window will automatically close after you have been logged out of that session.
Project 7B: Customizing Your Desktop Environment

Whichever user account you've decided to play with, you are now ready for action. We are going to start off easy by just creating folders, but by the time we get to the end of the process, you will have created a much wilder, and, depending on how you look at things, gaudier desktop environment than you've ever seen before. All of this is in good fun, of course, and when you are done, you should be able to completely and confidently customize things the way you want on your own. So let's go.

7B-1: Creating Folders

To get started, open your home folder. Unless you've been working on your own without me, there should be nothing there at this point except for the Examples folder, which I mentioned in Chapter 3, and a folder called Desktop, which basically contains any files, folders, and shortcuts to programs that you have put on your desktop. If you are anything like me, you will want to put an end to this rather empty state of affairs by creating some folders in which you can organize your files in the future.

The first folder you will create will be for your documents, which you'll call Documentia, though you can, of course, change the name later if you like. You can create a folder quite easily, much like you do in Windows, either by clicking the Nautilus File menu and then selecting Create Folder or by right-clicking in an empty space within the window and then selecting Create Folder from the popup menu. An untitled folder will appear.
Having a folder called untitled is, of course, a tad goofy, so you will want to change that. The text in the box below the folder will already be highlighted, so just type **Documentia**, and press ENTER. Once you have done that, the folder will show its new name.

Now you can repeat the process and create four more folders: Photos (for your photos, of course), Downloads (where you can dump any used files you will download along the way in this book), PDFs (for PDF files), and Music (for music files you will later learn to rip from music CDs with the program Sound Juicer). Once you have done all this, your home folder window should look like that in Figure 7-5.

![Figure 7-5: Adding folders to your home folder](image)

### 7B-2: Adding Emblems to Folders

You must admit, things do indeed look a bit better than before, but this is just the beginning. To graphically remind yourself what each folder is for, you can add little folder-top icons called **emblems**. These can be added to any folder or file. For now, let’s add one to the **Documentia** folder by right-clicking it and then, in the popup menu, selecting **Properties**. When the Properties window appears, click the **Emblems** tab and then scroll down until you see the emblem called Documents (Figure 7-6). Click the checkbox next to **Documents**, and then click the **Close** button. The emblem should now appear on your folder.

Now, for additional practice, try adding the **Sound** emblem to your Music folder. Just use the same steps as before, and substitute the appropriate items and entries.
Once you’ve added those two emblems, your folders should look a bit spunkier. Nevertheless, the background of the Nautilus window is still white. You need not stand for that if you don’t want to; you can change it as well. To do so, just go to the menu bar of your home window, click the Edit menu, and select Backgrounds and Emblems. The Backgrounds and Emblems window will then appear (see Figure 7-7).

From this window, you can drag any pattern into your home window, or into any other Nautilus window for that matter, and the pattern will then become the background for all your Nautilus windows. So, for experience’s sake, scroll down to find the pattern swatch called Manila Paper, and then drag it to the white space in the main pane of your home window. Once you’ve done that, the previously white window area will look like the wallpaper
in a lawyer’s office. Very nice, if you like that sort of thing. You can change it to a different background in the same way, of course, or you can go back to the default white by dragging the Reset swatch into the window.

**NOTE** If you prefer to use an image of your own for the Nautilus window background, you can also do so quite easily. Just locate the image in a new Nautilus window, click it with both the left and right mouse buttons (or just the middle mouse button, if you have a three-button mouse), and then drag the image to any open space within the target window. When you release the buttons, select Set as Background in the popup menu that then appears.

In addition to the buttons for pattern and color swatches, there is a third button in the Backgrounds and Emblems window called Emblems. Clicking the Emblems button reveals all of the emblems you saw in Project 7B-2 on page 103, thus providing you with another way to add emblems to your folders. This method is far handier when adding emblems to several folders or files in the same go.

To see how this works, click the Emblems button. Then drag the Camera emblem onto your Photos folder, Package onto your Downloads folder, and Special, for lack of a better choice, onto your PDFs folder. The selected emblems will then immediately appear on those folders.

### 7B-4: Dolling Up the Side Pane (and Emblems Yet Again)

Now let’s change the look of the Nautilus side pane. Keeping the Backgrounds and Emblems window open (if you already closed it, open it again), click the Places menu button in the Nautilus side pane, and select Information.

You can add a different background pattern to the side pane now as well, but for practice let’s add a color instead. To do this, click the Colors button in the Backgrounds and Emblems window. The window will now be filled with swatches of color. Drag the Grapefruit swatch to your side pane, and it will turn from gray to, of all things, grapefruit (albeit a very dark and unusually colored grapefruit). You can also create a two-color gradation effect by adding yet another color. Drag the Mango swatch to the bottom of the side pane (but still within the pane), and you should have a grapefruit-to-mango, top-to-bottom gradation within the pane. Of course, if you are not pleased with this tropical color set, you can get back to your original default gray panel by dragging the Reset swatch onto the area. When you’re done, you can close the Backgrounds and Emblems window.

The side pane of your Nautilus window provides yet a third way to work with emblems. But before I let you in on this third, and last, way, you will need to add two more folders to your home folder. Create one folder and name it Finances, which you can use to store files dealing with your relative worth in the modern scheme of things, and then create another and call it MyFaves, where you can place . . . well, your favorite files.

After you’ve created the new folders, go to the side pane, click the Information drop-down menu, and select Emblems. A list of emblems will appear within the side pane. Select the Money emblem, and drag it onto your Finances folder. Next, select the Favorite emblem, and drag it onto your
MyFaves folder. Your window should now look like that in Figure 7-8. Once you are done, go back to the drop-down menu and select Information to get everything back to relative normalcy again.

![Figure 7-8: Selecting emblems from the Nautilus side pane](image)

Even if it’s not your cup of tea, you have to admit that your Nautilus window is definitely more colorful now. You can, of course, change it to look however you want it to, but I’ll ask you to hold off on that a little while longer, because you are going to be doing a some more playing around with it shortly.

### 7B-5: Changing the Desktop Background

Now that your home folder window is all gussied up (or gaudied up, depending on your aesthetic sense of things), you may feel that your desktop looks rather drab in comparison.

Changing the desktop background (often called wallpaper) is easily achieved by right-clicking any open space on the desktop and selecting Change Desktop Background in the popup menu. This will bring up the Desktop Background Preferences window (see Figure 7-9).

#### Installing Additional Wallpapers

As you can see, the default wallpaper in Ubuntu is called Ubuntu Lagoon, but other than that there really isn’t much for you to choose from. To remedy the situation, you need to provide some images of your own. These could be photos from a digital camera, works of art you created on your computer, or just about anything you want to put there. In this case, however, you are going to venture out onto the Web to get and then install some wallpaper. A number of sites provide free desktop wallpaper, such as those for automobile manufacturers, singers, television shows, and so on.
Two sites specifically geared toward Linux users are www.kde-look.org and http://art.gnome.org, but for this chapter, I will be downloading some wallpaper from the Slovak LinuxOS.sk site. If you want to follow along using the same Tux-chases-the-Windows-varmints wallpaper that I use, go directly to the wallpaper image by pointing your web browser to www.linuxos.sk/downloads/wallpapers/4.jpg. When the picture appears in the browser window, right-click it, and then select **Save Image As**. In the Save Image window, give it a unique name (*4.jpg* doesn’t tell you much, after all) or use the one I gave it, *windowsroundup.jpg*, and click **Save**. If you prefer, you can download any wallpaper you like from wherever you like, as long as it is in a supported format, such as BMP, PNG, or JPEG. It’s all up to you.

Once you’ve downloaded your wallpaper, place it in your Downloads folder. After that, you can install it by going to the Desktop Background Preferences window and clicking the **Add Wallpaper** button. In the Add Wallpaper window that then appears, navigate to your new wallpaper, click it once to highlight it, and then click **Open**. The wallpaper will then appear highlighted in the Desktop Background Preferences window and will soon thereafter appear on the desktop itself (Figure 7-10). Once it does, click **Finish** to complete the process.

**Hiding the Bottom Panel**

By the way, you may have noticed that you can barely see the panel at the bottom of the screen in Figure 7-10. This is because the panel obscured the bottom of the new wallpaper, which irritated me. I went to the Panel Properties window by right-clicking some empty space in the bottom panel and selecting **Properties** in the popup menu. In the Panel Properties window, I clicked the checkbox next to the word **Autohide** and then clicked **Close**. The autohide function works just like it does in Windows or Mac OS X—the panel stays out of view until you move your mouse into the general vicinity of where it should be. You can make the same change if you like, but that is an aesthetic matter that I will leave up to you. Ah, the sweet taste of artistic freedom.
Searching the Internet for wallpaper to install can in itself be a rather fun adventure, but sometimes it can also feel like quite a chore. Fortunately for you, me, and all involved in such things, there is an even easier way: the Art Manager. The Art Manager, also known as GNOME Art, is a handy application that searches the art.gnome.org site, and downloads a list, with thumbnails, of all the wallpapers that are available there. It can also do this for the various window border, controls, and icon theme sets that you can use in the following parts of this project. Using the thumbnailed lists, you can easily download and install whatever you want—all without ever placing a cursor in your web browser. Needless to say, the Art Manager is decidedly cool!

Unfortunately, the Art Manager is not installed by default; however, after having gone through Chapter 5, you know how easy it is to download and install applications like the Art Manager. All you have to do is run Synaptic, do a search for `gnome-art`, and then install it.

You can then run Art Manager by selecting **System ➤ Preferences ➤ Art Manager**. The GNOME Art window will then appear with absolutely nothing in it. To put it to use, and relieve that emptiness, go to the **Art** menu, and select **Backgrounds ➤ GNOME**. (You can select **All** instead of GNOME if you like, but it will take longer to download the list of available wallpapers.)

Once your selection is made, the Art Manager will begin downloading a list of all that is available for you at the art.gnome.org site. When it’s done, you will see a list of thumbnails for you to choose from (Figure 7-11).
You can now install a wallpaper by scrolling down until you find one that suits your fancy, clicking it once to highlight it, and then clicking the Install button. Art Manager will then download it, install it, and then automatically open the Desktop and Background Preferences window so that you can immediately apply it to your desktop if you like. As I said before, it’s a very handy tool to have, especially since you’ll be using it more soon within this project.

7B-7: Changing Window Borders, Controls, and Icon Sets

Now we get to my favorite part of this journey through the world of digital cosmetic surgery—changing the way window borders and controls look in GNOME. Let’s set about doing just that.

The procedure is really quite easy. Go to the System menu, and select Preferences ➤ Theme. The Theme Preferences window will open and show you a list of the themes that are installed on your system (see Figure 7-12). The default theme in Ubuntu is called Human, but, as you can see, there are many others as well.

To get the hang of things, have a look at each of the themes listed by clicking them one by one. The changes will take effect immediately. Just clicking on a theme will change your window borders, controls, and even, if you take a peek in your home folder, the icons. This is especially noticeable when you click Crux or Grand Canyon.

Each theme consists of a window border, a set of controls, and a collection of icons. This being the case, it is possible to mix and match these elements on your own. For example, let’s say that you like the look and color of the bubbly controls in Grand Canyon, but you prefer the window borders in Mist and the icons in Ocean Dream. Well, you needn’t despair, because you can create a custom theme consisting of these three different elements.
To create your own mix-and-match theme, just click the Theme Details button in the Theme Preferences window. A new window will open, and you will find three tabs: Controls, Window Border, and Icons. From within each of these tabs you can select the components you prefer. First click the Controls tab, and select Grand Canyon. Then click the Window Border tab, and select Mist. Finally, click the Icons tab, and select Sandy, which is the icon set for the Ocean Dream theme.

Now keep the Theme Details window open, but open your home folder and take a look at what you’ve done. Hmm . . . not bad. But, perhaps you don’t really like the look of those Mist window borders all that much. To find something that suits you better, click the Window Border tab again, and scroll down until you see something you do like (Crux seems to do the trick for me), and click that. Better? Now that you are satisfied, you can click the Close button.

You will now be back at the Theme Preferences window, where you will notice that at the top of the list, there is a new theme entry called Custom Theme. If you want to save this new combination for later use, click the Save Theme button. Doing so will open a dialog box in which you can name your theme and write a brief comment about it. So, name your theme, write a comment if you like, and then click Save. Your new theme will now appear in alphabetical order within the theme list under the name you chose.

Once that’s all done, your home folder window should look like that in Figure 7-13 (and take a look at your panel and Applications menu while you’re at it). Ah, trés cool!
Figure 7-13: Changing the look of the home folder window

7B-8: Installing Additional Window Borders, Controls, and Icons

If you are excited about this customization thing but you’re not satisfied with the theme choices included with the system, you can download and install still other window borders, controls, and icons. To show you how to do this, I will walk you through creating a faux Mac theme, which will look fairly similar to the standard Aqua theme of Mac OS X, as you can see in Figure 7-14.

Figure 7-14: An Aqua-fied Ubuntu desktop
Getting and Installing the Files You’ll Need

To get the files you’ll need to do this, take the Art Manager for another ride. Once it is up and running, go to the Art menu, and select **Backgrounds ▶ Other**. Once the list of available wallpapers appears in the Art Manager window, scroll down until you find one called **Real shoot**, install it, and then apply it in the Desktop Background Preferences window, which will automatically open.

Now to get an appropriate window border for your new theme, go back to the Art menu, but this time select **Desktop Themes ▶ Window Border**. Look for one called **Hacked**, and install it. When the Theme Preferences window automatically appears, click the **Theme Details** button, and click the **Window Borders** tab. In the list that appears in that tab, click **Hacked**. Close the Theme Details and Desktop Background Preferences windows to complete the task.

Next get a set of matching application control widgets by going back to the Art Manager **Art** menu and selecting **Desktop Themes ▶ Application**. When the list is downloaded, look for a file called **Yattacier 3**, and install it. In the Desktop Background Preferences window that then appears, click **Theme Details** as you did before—but this time around click the **Control** tab, and select **Yattacier3** in the list within that tab.

To round things up, let’s add some new icons to the mix by going back to the Art Manager, heading to the **Art** menu, and selecting **Desktop Themes ▶ Icon**. Once the list is downloaded, look for and install **Snow-Apple**. After that it’s basically a repeat of the previous step, but this time around, click the **Icons** tab in the Theme Details window, and then select **Snow Apple**.

Finishing Touches

Well, things are certainly sort of Mac-ish now, but there is even more we can do to emphasize the effect. First, open a Nautilus window, click the **Computer** button, and then drag the **Filesystem** icon to your desktop. This will create an alias of your hard disk there. Next, go to the bottom panel, and remove everything except Trash. After that, open the Preferences window for your bottom panel by right-clicking the area to the far right of Trash and selecting **Properties** in the popup menu. In the **General** tab of that window, uncheck **Expand**, and then increase the size of the panel to around 54 pixels. When you’re done, click **Close**, and then start adding launchers for the applications you use most.

Finally, go to the top menu, and remove the three icons next to the **System** menu. After that, add a **Window Selector** applet, so that you have some way to navigate through your open windows. You might also want to change the background in your home folder, since the warm tones presently there no longer match your new cooler configuration.

The transformation is now complete, and if you followed along correctly, your desktop should look something like mine back in Figure 7-14. You can stick with your new OS X-ish theme, or switch to something else. For consistency’s sake, I will switch back to **Human** now. By the way, if you do decide to keep the faux-Aqua theme, remember to click the **Save Theme** button in the Theme Preferences window and give the theme a name.
Project 7C: Placing Hard Disk and Trash Icons on the Desktop

As you are already aware, unlike Windows, Mac OS X, or other Linux distributions, Ubuntu has a completely empty desktop upon installation. A lot of people advocate this approach because it discourages the permanent use of the desktop as a location to store files and program launchers. After all, as the argument goes, you don’t place your trash can or file cabinet on the desktop in your office, do you?

All such logic aside, there are still many people who prefer to have their trash can, hard disk, and home folder on their desktops, thank you very much. If you are one of them, as I am, here’s what you need to do:

1. Press ALT-F2 to bring up the Run Application window. This keyboard shortcut is the equivalent of clicking the Run Application panel applet that you placed on the panel in your original user account.
2. Run the GNOME Configuration Editor by typing `gconf-editor` in that window and then pressing ENTER.
3. When the Configuration Editor window appears, click the small arrow next to apps, scroll down to nautilus, and click the small arrow next to that.
4. Click desktop in that expanded nautilus section, after which the options for that item will appear in the right pane of the window (Figure 7-15).

![Figure 7-15: The Configuration Editor](image.png)

5. Check the boxes next to the items you would like to appear on the desktop. You have four unchecked choices to choose from: computer_icon_visible (like My Computer in Windows), documents_icon_visible, etc.
(to create a link to your Documents folder, if you have one), home_icon_visible (for quick access to your home folder), and trash_icon_visible (for you-know-what).

6. When you’re done, close the Configuration Editor.

**NOTE** Changes made in the way I just described will affect all user accounts. If you choose, for example, to show the trash can on the desktop for one user account, it will appear there for all others.

**Project 7D: Changing Your Login Screen**

You may have noticed while working with the Art Manager that there is a menu selection (Art > Other Themes) for something called Login Manager. The Login Manager is your login screen, also known as a greeter—the screen where you type your username and user password when you first log in to your system. The Login Manager is another thing that you can customize, but be forewarned that any changes you make will be system-wide, not just for you; whatever Login Manager theme you install and choose will be the Login Manager theme that everyone else with user accounts will see when they use the machine. Of course, if you are the only one using your machine, this point is moot.

**7D-1: Downloading a Login Manager Theme**

In order to try customizing the Login Manager, run the Art Manager, and select Art > Other Themes > Login Manager. Once you’ve done this, browse through the various themes in the list, and choose one or two that you want; I give you free rein on this one, but I’ll be choosing the theme called SVG Sakura, in case you want to follow along exactly.

Unlike your other experiences with the Art Manager up to now, Login Manager themes can only be downloaded, and you have to do the installation yourself. That being the case, once you’ve made your selection, click the Download Only button. Once the download is complete, you will find the file in archive form, with a tar.gz ending, in your home folder, or any other folder you decided to save it to. You do not need to extract, or untar, the archived file.

**7D-2: Installing Your New Login Manager Theme**

Once you’ve downloaded a theme or two of your liking, you need to open the Login Screen Setup window. To do this, go to the System menu, and select Administration > Login Window. A dialog box asking for your password will then open. Type the password for the account you are currently using, and click OK. The Login Window Preferences window will soon appear (see Figure 7-16), showing a thumbnailed list of the greeters available.

You can add the greeters you just downloaded to this list by dragging the files directly to the list. A small window will then appear, asking if you’re sure that you want to install the file you’ve just dragged to the list, and since you do want to install the file, click Install.
To select the greeter you wish to use, just click the round button next to its name in the list in the Login Window Preferences window, and then click the Close button. Of course, to see your greeter in action, you will have to log out first so you can log back in, but you needn’t restart or shut down the machine. You can then see your new greeter when the login screen appears (Figure 7-17), though yours may well be different.
Project 7E: Changing Your Splash Screen

Well, now you’ve changed just about all there is to change system-wise, but there is actually one more item that you can tinker with—your splash screen. In case you’re not familiar with the term splash screen, it’s the screen that appears when GNOME is starting up right after you log in but before you get to your desktop. The default screen, shown in Figure 7-18, is pleasant enough, but you can choose something a bit wilder or at least more colorful if you are so inclined.

Figure 7-18: The default Ubuntu splash screen

7E-1: Installing New Splash Screens

Ubuntu does not come with any alternative splash screens for you to play with, so in order to make changes, you first need to download and install some splash screens with which to work. This can be done quite easily by opening Art Manager (System ➤ Preferences ➤ Art Manager) and following these steps:

1. Go to the Art menu, and select Other Themes ➤ Splash Screen. Art Manager will then download the available splash screens.
2. Once the download is complete, scroll through the offerings, and select one that suits your fancy by clicking it once.
3. After your selection has been made, click the Install button, after which Art Manager will download and install the file. When it’s done, the GNOME Splash Screen Preferences window will appear, showing the newly installed screen.
4. Go back to the Art Manager, and repeat steps 2 and 3 to add a few more screen choices to your repertoire.
5. Once you have installed three or four splash screens, close Art Manager.
Enabling Automatic Login

While the Login Window Preferences window is open, it is as good a time as any to mention an option that may well be of interest to you. If you find it a bit of a drag to type your username and password every time you start up your machine, you’ll be happy to know that you can bypass the whole login process. If you share your machine with other users, of course, this isn’t something you’d want to do because anybody with access to your user account would thus have access to your user account. I also wouldn’t recommend doing so on a laptop, since they are more easily lost or stolen, thus leaving your data at risk to absolute strangers.

To enable automatic login, click the Security tab in the Login Window Preferences window, and then click the checkbox at the top of the page, next to the words Enable Automatic Login. After that, click the arrow at the right side of the drop-down menu, next to the word User, and select your username from the list. Once you’re done, click the Close button. The next time you start up your machine, you will bypass the login screen and be delivered directly to the desktop.

7E-2: Selecting and Activating Splash Screens

When you have multiple splash screens installed on your system, you can select and then activate them via the GNOME Splash Screen Preferences window (Figure 7-19), which should already be open. When it isn’t, you can bring it up by going to the System menu and selecting Preferences → Splash Screen.

![Figure 7-19: Choosing a new login screen](image)

To select and then activate a splash screen, make your selection by clicking on the splash screen of your choice once, and then click the Activate button. You will then see your splash screen in action when you next log in to your system.
Choosing a Screensaver

Screensavers used to be a must-have (and must-use) item for computer users who wanted to prevent damage (burn-in) to their monitors. Video display technology, however, has now advanced to the point where screensavers are no longer completely necessary. Nevertheless, screensavers are cool to look at, and one very nice thing about Ubuntu is that it comes with an unusually extensive collection of screensaver modules—nearly 200 of them! There are so many that you are sure to find at least a few you like. The screensaver settings are preconfigured to switch between modules randomly, changing the current module every few minutes. You can change these settings by going to your System menu and selecting Preferences ▶ Screensaver.

The Screensaver Preferences window, shown in Figure 7-20, allows you to do a variety of things, such as set the length of time between module changes and the length of idle time before the screensaver starts up. You can also opt to use only one screensaver module or no screensaver at all. In random mode, you can also omit the modules that you don’t like by unchecking the boxes next to the undesired modules’ names. This can be quite useful, especially if certain screensavers seem to tax the graphic capabilities of your machine.

![Figure 7-20: Setting screensaver preferences](image)

Project 7F: Wrapping Things Up—Installing and Applying Firefox Themes

It’s time to bring this rather lengthy exercise in customization to a close. Now that you know how to do most of the things you might want to do in this area, you can return to your own user account and use what you’ve learned to make changes that suit your own tastes and desires.
If you’ve really gotten hooked on this customization thing, you’ll be happy to know that there are always more things you can bend to your will. In addition to being able to customize your system sounds, the splash screen that appears after you log in, and the system fonts that are displayed in your menus and folders, you can also play around with the many applications that allow customizations through the use of skins designed specifically for those apps.

Perhaps the most notable of these customizable applications is Firefox, which you first met in Chapter 4. Firefox allows you to change the look of its buttons, application controls, and even background colors through the use of themes, some examples of which you can see in Figure 7-21. You will be glad to learn that downloading and installing these themes is a fairly straightforward process, so to finally wrap things up, I will end this chapter by providing you with the steps you need to follow:

1. In Firefox, go to the Tools menu, and select Themes. The Firefox Themes window will then appear.
2. In the bottom-right corner of that window, click the Get More Themes link.
3. A new Firefox window listing available themes will then appear. Click any of the links to see a preview of that theme, or browse the available themes categorically by clicking the category links at the left side of the page.
4. When you find a theme you like, click the Install Now link on the page for that theme.

Figure 7-21: Firefox themes
5. A confirmation window will then appear, asking if you’re sure that you want to install the theme in question. Click **OK**.

6. Once the theme is downloaded and installed, it will appear in the list of available themes in the left pane of the Themes window (Figure 7-22). Select the theme you want to use by clicking it once, and then click the **Use Theme** button.

7. Restart Firefox to see your new theme in action.

![Figure 7-22: Selecting Firefox themes](image)